Manual para PseInt

Muchos se preguntaran como se utiliza este programa en esta entrada se enseñara como hacerlo y con un video incluido al final.

Lo primero que se debe saber es que este es un programa que ocupa PseudoCódigo, por lo tanto todo programa que se escriba en este, debe comenzar con la palabra clave Proceso seguida del nombre del programa, luego le sigue una secuencia de instrucciones y finaliza con la palabra FinProceso;

Proceso <nombre> <secuencia de instrucciones> FinProceso

Donde una secuencia de instrucciones (Algoritmos) es una lista de una o más instrucciones, cada una terminada en punto y coma ( solo las instrucciones se terminan en punto y coma).

 <instrucción>; <instrucción>; ... <instrucción>;

Si se desea se pueden escribir comentarios luego de una instrucción, esto
mediante el uso de la doble barra ( // )

asignación:

La instrucción de asignación permite almacenar una valor en una variable.

 <variable> <- <expresión> ;

Al ejecutarse la asignación, primero se evalúa la expresión de la derecha y luego se asigna el resultado a la variable de la izquierda. El tipo de la variable y el de la expresión deben coincidir.

Ejemplos :

var <- 1; // asigna el número 1 a var Acumulador <- Acumulador + 1; // incrementa el valor del Acumulador en 1

Entrada/Salida:

Es un instrucción que tiene que ver con la entrada de información, como por ejemplo, ”Leer” permite ingresar información desde el ambiente.

Leer <variablel> , <variable2> , … , <variableN> ;

Esta instrucción lee N valores desde el ambiente (en este caso el teclado) y los asigna a las N variables mencionadas. Pueden incluirse una o más variables, por lo tanto el comando leerá uno o más valores.

Ejemplos :

Leer Cantidad; Leer Valorl,Valor2,Valor3;

La instrucción Escribir permite mostrar valores al ambiente.

 Escribir <exprl> , <expr2> , ... , <exprN> ;

Esta instrucción imprime al ambiente (mostrar, en este caso en la pantalla) los valores obtenidos de evaluar N expresiones. Dado que puede incluir una o más expresiones, mostrará uno o más valores.

Ejemplos

Escribir "Ingrese el nombre:"; Escribir "Resultado:" , x*2 ;

Mientras Hacer:

La instrucción Mientras ejecuta una secuencia de instrucciones mientras una condición sea verdadera

Mientras <condición> Hacer <instrucciones> FinMientras

Al ejecutarse esta instrucción la condición es analizada y se repite la secuencia de instrucciones mientras la condición siga siendo verdadera. Las instrucciones del cuerpo del ciclo pueden no ejecutarse nunca si al ser analizada por primera vez resulta ser falsa, por lo contrario si esta siempre es verdadera se produce un ciclo infinito.

Ejemplo :

 Escribir "Ingrese un número (0 para salir)"; Leer a; Mientras a<>0 Hacer Tot <- Tot+a; Escribir "Ingrese otro número (0 para salir)"; Leer a; FinMientras Escribir "Total:",Tot;

Repetir hasta que:

Esta instrucción ejecuta una secuencia de instrucciones hasta que la condición sea verdadera, si la condición es falsa el cuerpo del ciclo se ejecuta nuevamente y se vuelve a evaluar la condición.

Repetir <instrucciones> Hasta Que <condición>

Ejemplo :

 Repetir Tot <- Tot+a; Escribir "Ingrese un número (0 para salir)"; Leer a; Hasta Que a=0; Escribir "Total:",Tot;

Para:

Ejecuta una secuencia de instrucciones un numero determinado de veces

Para <variable> <- <inicial> Hasta <final> ( Con Paso <paso> ) Hacer <instrucciones> FinPara

Ejemplo :

 Escribir "Números pares de 10 a 20:"; Para a<-10 Hasta 20 Con Paso 2 Hacer Escribir a; FinPara

Operadores:

Operador Significado Ejemplo
Relacionales
> Mayor que 3>2
< Menor que ‘ABC’<’abc’
= Igual que 4=3
<= Menor o igual que ‘a’<=’b’
>= Mayor o igual que 4>=5
Lógicos
& Conjunción (y). (7>4) & (2=1) //falso
| Disyunción (o). (1=1 | 2=1) //verdadero
~ Negación (no). ~(2<5) //falso
Algebraicos
  Suma  
* Multiplicación
/ División
^ Potenciación

Fuente http://pseint.sourceforge.net/manual.html#Utilizaci.C3.B3n_del_entorno

Video con ejemplo, para comprender mejor el uso de este programa.

About these ads

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s